-
Docker的overlay2占用大量磁盘空间的问题通常源于多个方面,包括容器日志文件过大、未清理的容器和镜像、默认存储路径设置不当等。以下是一些具体的解决方法:一、检查磁盘空间占用情况;二、清理日志文件;三、清理未使用的容器和镜像
-
使用docker stats命令查看容器资源使用情况:docker stats。docker stats命令显示实时运行容器性能消耗情况。
-
Docker是一个开源的应用容器引擎,让开发者可以打包他们的应用以及依赖包到一个可移植的容器中,然后发布到任何流行的Linux机器上,也可以实现虚拟化。以下是一份详尽的Docker命令大全,旨在帮助用户更好地管理和操作Docker。
-
docker 默认挂载目录相对于 /var/lib/docker/volumes。docker 会将数据卷 volume 存放在宿主机的默认路径/var/lib/docker/volumes/ 目录下面。如果不想挂载到 /var/lib/docker/volumes 目录下,可以指定绝对路径。
-
在 docker 容器中使用宿主机 ssh key 的方法。将 docker 容器 /root/.ssh 目录挂载到 ~/.ssh 目录。
-
docker run :创建一个新的容器并运行一个命令。docker run 语法:docker run [OPTIONS] IMAGE [COMMAND] [ARG...]。
-
docker 删除镜像的命令是 docker rmi ,可以删除一个或多个本地镜像
-
docker删除所有容器镜像的命令:docker images -q | xargs docker rmi
-
修改 docker registry 的方法,vi /etc/docker/daemon.json。Get /binary-mirror-config/latest from https://registry.nlark.com error: Error: getaddrinfo EAI_AGAIN registry.npmjs.com at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26) Get /bug-versions/latest from https://registry.nlark.com error: Error: getaddrinfo EAI_AGAIN registry.npmjs.com。解决方法:修改 docker 镜像源,vi /etc/docker/daemon.json
-
docker logs命令用于获取容器日志。-f 跟踪日志输出;--since 显示某个开始时间的所有日志;-t 显示时间戳 --tail 仅列出最新N条容器日志。示例:docker logs --since="2021-01-01" --tail=5 fe-redis。
-
Redis(Remote Dictionary Server ),即远程字典服务,是一个开源的使用 ANSI C 语言编写、支持网络、可基于内存亦可持久化的日志型、Key-Value 数据库,并提供多种语言的 API。使用 docker 安装 redis:docker pull redis
-
Docker Compose 安装方法:sudo curl -L "https://github.com/docker/compose/releases/download/1.24.1/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
-
Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade。{"t":{"$date":"2024-11-01T02:23:50.203+00:00"},"s":"W", "c":"STORAGE", "id":22347, "ctx":"initandlisten","msg":"Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade."}
{"t":{"$date":"2024-11-01T02:23:50.203+00:00"},"s":"F", "c":"STORAGE", "id":28595, "ctx":"initandlisten","msg":"Terminating.","attr":{"reason":"95: Operation not supported"}}
{"t":{"$date":"2024-11-01T02:23:50.203+00:00"},"s":"F", "c":"-", "id":23091, "ctx":"initandlisten","msg":"Fatal assertion","attr":{"msgid":28595,"file":"src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine.cpp","line":687}}
{"t":{"$date":"2024-11-01T02:23:50.203+00:00"},"s":"F", "c":"-", "id":23092, "ctx":"initandlisten","msg":"
***aborting after fassert() failure
"}
-
docker inspect 命令是 Docker 中一个强大的工具,它允许你深入查看 Docker 容器或镜像的详细信息。这些信息对于调试、监控以及理解 Docker 容器的运行环境和配置非常有帮助。以下是一份详细的 docker inspect 教程,带你一步步掌握如何使用这个命令。
-
docker exec 命令使用方法:docker exec [OPTIONS] CONTAINER COMMAND [ARG...]。-d 分离模式,在后台运行;-i 即使没有附加也保持STDIN 打开;-t 分配一个伪终端。
-
本文列举几种常见的docker配置dns方法。方法一:创建 docker 容器时指定 dns,docker run --dns=xx.xx.xx.xx DOCKER_IMAGE。方法二:在宿主机 /etc/docker/daemon.json 文件中进行配置。方法三:在宿主机 /etc/resolv.conf 文件中配置。
-
宿主机连接docker redis容器的方法
-
在 mongo docker 容器中执行命令 mongo,发现报如下错误:bash: mongo: command not found.这是因为Mongo DB 6.0 版本开始,不再提供 mongo 命令行工具,而是使用 mongosh。
-
docker 容器内运行命令提示 permission denied 解决方法:在运行 docker 容器时指定 -u root,赋予 root 权限
-
docker run 后面如果需要跟多个命令,可以将多个命令放在 "sh -c" 后面执行。docker run -i --rm DOCKER_IMAGE sh -c "rm -rf ./node_modules/* && yarn cache clean && npm run ci"